0.1.0 • Published 7 years ago

@arr/foreach.spec v0.1.0

Weekly downloads
-
License
MIT
Repository
github
Last release
7 years ago

arr Build Status

A collection of tiny, highly performant Array.prototype alternatives and extra utilities.

All exports are offered as CommonJS and ES6 modules. Additionally, every entry is ES3 code, which means that each package is ready for & compatible with any Browser or Node version!

Please view each package's readme for Usage and important information! :pray:

:warning: Note: Most functions have slight differences from the native built-ins!

To view extensive benchmark results, visit the Benchmarks section.

PackageVersionMinifiedNode 4Node 6Node 7Node 8
everynpm95 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
filternpm101 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
filter.mutatenpm90 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
findnpm91 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
findIndexnpm94 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
flattennpm151 B:wavy_dash::wavy_dash::wavy_dash::wavy_dash:
forEachnpm73 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
includesnpm95 B:wavy_dash::white_check_mark::no_entry_sign::mag:
mapnpm122 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
reducenpm137 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
reduceRightnpm130 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
reversenpm136 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
somenpm94 B:white_check_mark::white_check_mark::white_check_mark::white_check_mark:
uniquenpm111 B:wavy_dash::wavy_dash::wavy_dash::wavy_dash:

:white_check_mark: Denotes function is faster than native :no_entry_sign: Denotes function is not faster than native :mag: Denotes function is sometimes faster than native :wavy_dash: Denotes function has no native counterpart

License

MIT © Luke Edwards