1.0.0 • Published 2 years ago

@tanahatas/satpam-dependencies v1.0.0

Weekly downloads
-
License
Apache-2.0
Repository
github
Last release
2 years ago

Overview

When using npm or yarn, the default is to use the most recent release with the same major version. (For example, ^1.2.3 would accept version 1.9.1, but 1.2.3 would only accept version 1.2.3.) This package checks that the package dependencies are set as exact.

Installation

See the file INSTALL.md for installation instructions.

Usage

If there is a dependency that needs to be pinned, it will look like this.

✖ Dependency react should be pinned.
✖ Dependency react-dom should be pinned.

If there is no issue, it will look like this!

✔ No issues were found!

Basic usage

With npx

npx satpam-dependencies

With Yarn

yarn satpam-dependencies

With npm

  1. Add "satpam-dependencies": "satpam-dependencies" to the "scripts" section of package.json.
  2. npm run satpam-dependencies

Pre-Commit Hook

You can run satpam-dependencies as a pre-commit hook using Husky.

yarn add husky --dev --exact

In package.json, add:

{
  "husky": {
    "hooks": {
      "pre-commit": "satpam-dependencies"
    }
  }
}

Bug reports and user feedback

Please report bugs using the issue tracker at https://github.com/tanahatas/satpam-dependencies/issues

License

Licensed under the Apache License, Version 2.0.

I Love Coffee

ko-fi

1.0.0

2 years ago