0.0.22 • Published 1 month ago

@blitz/eslint-plugin v0.0.22

Weekly downloads
15
License
MIT
Repository
-
Last release
1 month ago

@blitz/eslint-plugin

An ESLint plugin to enforce a consistent code styles across StackBlitz projects

Installation

You'll first need to install ESLint:

$ yarn add -D eslint

Next, install @blitz/eslint-plugin:

$ yarn add -D @blitz/eslint-plugin

Note: If you installed ESLint globally (using the -g flag) then you must also install @blitz/eslint-plugin globally.

Usage

Add @blitz/eslint-plugin to the extends section of your .eslintrc.js or .eslintrc.json configuration file and and configure parser and parserOptions. For the plugin, you can omit the eslint-plugin-:

{
  "parser": "@typescript-eslint/parser",
  "parserOptions": {
    "ecmaVersion": 2019,
    "sourceType": "module",
    "ecmaFeatures": {
      "modules": true
    }
  },
  "extends": ["plugin:@blitz/recommended"]
}

Custom Rules

0.0.21

1 month ago

0.0.22

1 month ago

0.0.20

3 months ago

0.0.18

6 months ago

0.0.19

6 months ago

0.0.17

11 months ago

0.0.16

11 months ago

0.0.15

11 months ago

0.0.14

11 months ago

0.0.13

11 months ago

0.0.12

1 year ago

0.0.11

1 year ago

0.0.10

1 year ago

0.0.9

1 year ago

0.0.8

1 year ago

0.0.7

1 year ago

0.0.6

1 year ago

0.0.5

1 year ago

0.0.4

1 year ago

0.0.3

1 year ago

0.0.2

1 year ago

0.0.1

1 year ago