1.0.3 • Published 3 years ago

translit-npm v1.0.3

Weekly downloads
3
License
ISC
Repository
-
Last release
3 years ago

translitor-npm

Любишь транслит и строки "аре йоу думб?" (are you dumb?), тогда этот пакет для тебя!

Чтобы установить пакет себе в проект, нужно прописать следующее в терминале.

npm i --save translit-npm

Далее нужно подключить пакет с помощью require()

var translit = require('transit-npm');

Пользуемся!

.translitFromRussian(String russianString, Boolean onlyLowerCase)

Этот метод транслитит русский текст в английский, например:

var translit = require('translit-npm');

var string = translit.translitFromRussian('Я хочу быть человеком!')

// Output: Ya hochu bit' chelovekom!

.translitFromEnglish(String englishString)

Этот метод транслитит англ. текст в русский, например:

var string = translit.translitFromEnglish('...');

.translitForUrl(String russianString)

Этот метод не только транслитит русский текст в английский, а также делает из неё URL.

var string = translit.translitForUrl('Я хочу быть человеком!')

// Output: ya-hochu-bit-chelovekom
1.0.3

3 years ago

0.2.0

3 years ago

0.1.0

3 years ago